BETA

macOSとXcodeのバージョンアップしたらcarthageでエラーになった

投稿日:2019-04-13
最終更新:2019-04-13

今更ようやく会社のmacOSとXcodeをupdateしたら、carthageでエラーになった

Module compiled with Swift 4.2.1 cannot be imported by the Swift 5.0 compiler  

carthage updateはしてみたもののダメ。
xcode selectもちゃんと10.2を示しているのを確認。

よくよく見ると、carthageのbuildのframeworkの更新日が古いままだった。
試しに削除してbootstrapしても生成されない。
改めてログをじっくり読むと、 Could not find any available simulators for iOS とあった。

carthageのアップデートで解決した、という記事をみつけたので実行。
https://stackoverflow.com/questions/54017424/carthage-update-failure-saying-could-not-find-any-available-simulators-for-ios/54051178

brew upgrade carthage  

解決!
いつもありがとうstackoverflow!!

技術ブログをはじめよう Qrunch(クランチ)は、プログラマの技術アプトプットに特化したブログサービスです
駆け出しエンジニアからエキスパートまで全ての方々のアウトプットを歓迎しております!
or 外部アカウントで 登録 / ログイン する
クランチについてもっと詳しく

この記事が掲載されているブログ

日々のつまづきや失敗、発見を記録して生きたいのでござるよ。

よく一緒に読まれる記事

0件のコメント

ブログ開設 or ログイン してコメントを送ってみよう