BETA

国会図書館デジタルライブラリーダウンローダーを更新 2019年版

投稿日:2020-03-26
最終更新:2020-03-26

qiitaから移転。2020年3月26日

MacOSX 10.11
ruby 2.2.5 ー>ruby 2.3.0ー>ruby 2.3.8

国会図書館デジタルライブラリーダウンローダーを更新した。

GitHub - hitode909/kindairb: 近代デジタルライブラリーダウンローダ
https://github.com/hitode909/kindairb

2017年03月頃
「gem install kindai」出来ず、rubygem アップデートとSSLの証明書エラーに困る。(解決済み) - Qiita

#1.上記URLとの変更点

MacOSX 10.9.5ー>MacOSX 10.11
ruby 2.2.5 ー>ruby 2.3.8

$ brew install git  
$ brew install readline  
(readlineのパスを.bash_profileや.zshenvに記述し通すこと)  
(source ~/.zshenv又はsource ~/.bash_profile)  
$ RUBY_CONFIGURE_OPTS="--with-readline-dir=$(brew --prefix readline)"  
$ brew install rbenv  
(必要な場合は、$ rbenv install 2.3.8)  
$ rbenv global 2.3.8  
$ which ruby  
$ brew install [email protected]  

$ gem install rmagick  
$ gem install kindai  

libxml2が不要になっている。

#2.brew list -1を行うと次の通り。

autoconf  
bash  
cmake  
doxygen  
freetype  
gettext  
git  
[email protected]  
jpeg  
libpng  
libtiff  
libtool  
little-cms2  
openjpeg  
openssl  
pcre2  
pkg-config  
rbenv  
ruby-build  
sphinx-doc  
webp  
xz  

bashを除く。
kindai.rbインストールに、libxml2が不要になっている。
とてもありがたい。

#3.kindai.rb でダウンロード確認。

kindai.rb URLにてダウンロード出来ることを確認済。

kindai.rb作者様に感謝。

(SSLの問題を確認しようと思って、未だにやってないな。(^_^;))

以上

技術ブログをはじめよう Qrunch(クランチ)は、プログラマの技術アプトプットに特化したブログサービスです
駆け出しエンジニアからエキスパートまで全ての方々のアウトプットを歓迎しております!
or 外部アカウントで 登録 / ログイン する
クランチについてもっと詳しく

この記事が掲載されているブログ

@shiroyoneの技術ブログ

よく一緒に読まれる記事

0件のコメント

ブログ開設 or ログイン してコメントを送ってみよう